Closing Market Data/Document Processing Delays
Incident Report for RamQuest Systems
Resolved
This incident has been resolved.
Posted Jun 17, 2019 - 10:17 CDT
Monitoring
Our data processing infrastructure is indicating a delay in our document and data delivery. This issue has been identified and resolved. We are continuing to monitor. No data has been lost and the system should be caught up shortly.
Posted Jun 17, 2019 - 09:11 CDT
This incident affected: Closing Market.