Closing Market Data/Document Processing Delays
Incident Report for RamQuest - op2 - Closing Market
Resolved
This incident has been resolved.
Posted Jul 24, 2019 - 17:21 CDT
Identified
We have identified the root of this issue and are working as quickly as possible to get it resolved.
Posted Jul 24, 2019 - 12:22 CDT
Investigating
Our data processing infrastructure is indicating a delay in our document and data delivery. No data has been lost and the system should be caught up shortly.
Posted Jul 24, 2019 - 10:56 CDT
This incident affected: Closing Market.