RamQuest Support Bulletin: Main Support Number Issue
Incident Report for RamQuest - op2 - Closing Market
Resolved
We have been monitoring the system and have seen no further interruptions in service. This is the last update on the status of this issue that we will post.

We apologize for the disruption and thank you for your patience while worked to resolve the issue.
Posted Mar 31, 2020 - 17:05 CDT
Monitoring
The issue with the main RamQuest Support number has been identified and resolved. We will continue to monitor the system to ensure no further interruptions and will post any additional information to the status page.

We appreciate your patience as we worked to resolve this issue.
Posted Mar 31, 2020 - 16:48 CDT
Investigating
RamQuest is currently experiencing technical difficulties due to an issue with our telephone service provider that is impacting our main telephone support number. In order to minimize interruptions, please use these alternative numbers to contact RamQuest support until the issue is resolved :

214-291-1600 option 2,
469-304-2607,
1-888-840-9005 or
1-800-542-5503 option 2

As always you can continue to contact RamQuest's Support team through email at support@ramquest.com, which we monitor and will respond as quickly as possible. Or you can reach us through our Live Agent Chat. To start a Chat Session, simply log into the customer portal and click the Live Agent Chat icon and you'll be prompted for your name, email address, phone number and details about your request, which will be immediately transmitted to the next available Support Team member who will then join your chat session.

If you do not already have access to Live Agent Chat you must be a member of the customer portal and becoming one is quick and easy. Just send an email to rqportal@ramquest.com and the RamQuest Support Team will process your request.
Posted Mar 31, 2020 - 15:39 CDT
This incident affected: RamQuest Support Center.